![]() |
| ||
|
|
Новости |
Поиск |
FAQ |
Статьи |
Книги |
Новости VCL
| | Форумы ЧАТ |
Орешник |
|
| |||
| |||
« предыдущая ветвь | форум | следующая ветвь »
Как организовать собственный SMTP сервер ?
Dmitriy_0 © (2002-01-29 16:24:00)Может кто знает? А то сейчас все сервера не позволяют relaying,
а надо.
Dmitriy_0 (2002-02-12 09:03:00) [1]А может кто знает такие сервера в инете?
Если бы мне удалось найти пару-тройку, то проблема бы отпала сама собой.
Ghost. (2002-02-12 09:01:00) [2]Спасибо господа я сам нашел (правда до конца не разобрался) а написано об этом в RFC 974 :0)
Dimk (2002-02-12 02:41:00) [3]Ну можно получить такую информацию если считать зону c DNS сервера. Но тут проблема - если надо это делать автоматически то надо читать доку по DNS. А если у тебя есть гдето под боком юниксоиды - ты к ним сходи. Они тебе покажут как зона делается.
Там есть такие МХ-записи - в них перечислены все почтовыe сервера в зоне.
Ну а потом останется только подумать как все это взять. У юниксоидов же спроcи RFC и все получится наверное :o)
SV (2002-02-11 18:29:00) [4]См. также
RFC 1123
RFC 821 (SMTP)
RFC 1891 и 1869 ESMTP тобишь расширения.
Больше у меня ничего нету. Удачи.
SV (2002-02-11 18:18:00) [5]http://developer.com.ua/rfc.php?act=search&text=SMTP
;)
Ghost. (2002-02-11 12:31:00) [6]Да хорошо бы найти где это описанно
Ghost. (2002-02-11 12:27:00) [7]Но всетаки может то подскажет где описана технология определения СМТП сервером через ДНС куда всетаки надо все отправлять, ведь все знают, что хост чаще всего не совпадает например маил.ру одно а смтп.маил.ру другое или в каком РФЦ это написано?
Dmitriy_0 (2002-02-11 12:17:00) [8]Вот! Именнно все это (что в этом компоненте) мне и нужно, только по этой ссылке - демо версия и исходники стоят 40 баксов.
У меня таких бабок нет :(
Ghost. (2002-02-11 10:51:00) [9]Вот и под 6-ю нашел..посмотри если поможет..сам не разбирался
http://www.legitima.com/delphi.htm#TSmtpRelayServer
Ghost. (2002-02-11 10:36:00) [10]Для 5 Делфи есть компонент такой, но без исходников поэтому в 6 не работает..он именно СМТР сервер, работает только на отправку через себя ,а какие в нем есть функции еще я не знаю
Dmitriy_0 (2002-02-11 09:19:00) [11]Мне это нужно в программу вставить. Программа не будет заниматься массовой рассылкой, поэтому готовые сендеры мне не подходят. Может знаешь, где исходники найти ?
}{unter (2002-02-04 12:26:00) [12]Зачем изобретать колесо !
Есть прекрасный софт MDaemon от DeerField
Там есть всё и relaying и любая виндовская платформа
Dmitriy_0 (2002-02-04 10:17:00) [13]Неб мне надо это реализовать в программе, чтобы работало везде, а не только где IIS стоит
SV (2002-01-31 13:09:00) [14]Читай RFC по SMTP ;)
SV (2002-01-31 13:09:00) [15]Читай RFC ;)
Ghost. (2002-01-30 15:34:00) [16]Тада можно ваще ничего не писать, а взять готовое
OlegR (2002-01-30 12:59:00) [17]Ставишь стандартный SMTP-сервер входящий в комплект IIS и отправляешь всю почту через него.
Ghost. (2002-01-30 12:40:00) [18]Интересный вопрос..я сам сервр писал..но отправку осуществлял через какойнибудь другой..а ты хочешь я так понял сразу адресату?