Top.Mail.Ru
Мастера DELPHI, Delphi programming community Титульная страница Поиск, карта сайта Написать письмо 
| Новости | Поиск | FAQ | Статьи | Книги | Новости VCL |
| Форумы ЧАТ | Орешник | KOL и MCK |
Форумы -» Основная («Начинающим»)/ Базы / WinAPI / Компоненты / Сети / Media / Игры / Corba и COM / KOL / FreePascal / .Net / Прочее / RSDN.ORG

« предыдущая ветвь | форум | следующая ветвь »

Маршрут пакета [D6, Win2k]


Страницы:   1 2

Brand ©   (2002-06-15 23:14:00) 

Хотелось-бы средствами Делфи определить через какие IP-адреса проходят пакеты от меня к серверам и обратно, а потом если-бы еще каким-то образом сформировать пакет, чтоб он автоматически проходил по тем-же определенным адресам, чтобы уже не бродил по Интернету в поисках пути!!! :)))


Malder   (2002-06-22 00:06:00) [1]

www.ya.ru: "VPN"


brand   (2002-06-21 18:45:00) [2]

А где можно про это почитать, потому-что я первый раз об этом слышу?


Malder   (2002-06-21 16:09:00) [3]

А чего сложного ?
VPN в виндовс встроен. ВПИ сервер есть в NT server


Brand   (2002-06-21 09:45:00) [4]

Ничего себе. Не думал, что это так сложно.


Malder   (2002-06-20 16:26:00) [5]

Хм. А действительно. Пришла идея так сказать. А почему бы на использовать VPN ? И VPN клиентом дозваниваться до локалки.


Malder   (2002-06-20 02:34:00) [6]

М-м-м. Не знаю. Вторичное соединение в виндовс можно установить с помощью программы COM/IP. Это со стороны клиента. А вот со стороны сервера. Даже не знаю. Сервер должен "принять вызов", установить PPP соединение и выделить IP. Сложно это думаю. Но если интересно - могу поспращивать людей, может что подскажут.


brand   (2002-06-19 15:29:00) [7]

>Malder
Класс, мне нравится. Есть такой гейт в локалке. Аааа, как это программными средствами сделать?


Malder   (2002-06-19 12:50:00) [8]

Brand, IP адреса обычно не называют реальными и нереальными. А называют внешними и внутренними. Так вот, чтобы связаться с компом в инете, он должен иметь внешний IP.
Хотя в твоем случае есть варианты. Если какой-нибудь компьютер (роутер) (который имеет IP как внутир локалки, так и в интернете) выступит в качестве гейта, то можно подлючиться к локальной сети. То есть открыть вторичное соединение с присвоением интранет адреса. Возможны и другие варианты...


Wonder   (2002-06-19 12:09:00) [9]

А в этой ситуации тебе не поможет и явное задание маршрута, потому как его просто не существует.
Маршрутизация подразумевает под собой связь между сетями и подсетями некой глобальной сети (как интернет).
Твоя локальная сеть не является частью инета, поэтому разговор о маршрутизации тут вообще неуместен.


Brand   (2002-06-18 23:02:00) [10]

>Wonder
Пусть у меня есть комп в локальной сети с нереальным IP=192.168.0.1
У сервера моей локальной сети, который подключается к инету через Dial-Up пусть провайдер к примеру присвои реальный IP=190.132.32.43
Так вот, как мне к примеру с совсем левого компа к примеру с адресом IP=180.32.43.43 послать пакет именно моему компу (IP=192.168.0.1)?
Как-же это надо настроить TCP/IP чтоб он сам со всем разобрался?


Malder   (2002-06-18 13:09:00) [11]

Абсолютно согласен с Wonder.
Хотелось-бы средствами Делфи определить через какие IP-адреса проходят пакеты от меня к серверам и обратно
почитай в RFC про tracerout и как это делается.

, а потом если-бы еще каким-то образом сформировать пакет, чтоб он автоматически проходил по тем-же определенным адресам, чтобы уже не бродил по Интернету в поисках пути!!!
ты не сможешь этого сделать. Да и это противоречит принципам Internet. Настройка маршрутизации не твоя задача. Если ты видишь, что твой трафик в америку идет через Новую Гвинею - то ты в принципе можешь обратиться к провайдеру, чтобы он связался с соответствующими людьми и это было исправлено. Хоя не исключено, что через Новую Гвинею твой пакет дойдет быстрее, чем по другому пути...


Wonder   (2002-06-18 11:29:00) [12]

>Brand
Изучай принципы взаимодействия в TCP/IP сетях.
Смею тебя заверить, что при правильной настройке, TCP/IP сам, без твоей помощи, разберется с маршрутизацией :)


Brand   (2002-06-17 23:08:00) [13]

>Wonder
А если у меня компьютер в локалке. Как мне принять пакет, не зная, через какой (какие) комп (компы) я подключаюсь к инету???
А так я знаю полный маршрут и по Инету и по локалке и соответственно пакеты будут проходить через все эти ИП прям ко мне.


Wonder   (2002-06-17 12:07:00) [14]

"Хотелось-бы средствами Делфи определить через какие IP-адреса проходят пакеты от меня к серверам и обратно"

traceroute. Реализуется по аналогии с ping-ом.

"а потом если-бы еще каким-то образом сформировать пакет, чтоб он автоматически проходил по тем-же определенным адресам, чтобы уже не бродил по Интернету в поисках пути"

Зачем?


МИФИст   (2002-06-16 23:31:00) [15]

Попробуй найти книгу Ю.А.Семенова "Протоколы и ресурсы internet" (Радио и Связь)
Вместо * поставь нужную цифру:
http://wood.lesobank.ru/projects/docs/rfc/rfc*.html

IGP: RFC-1074, 1371
IGRP: RFC-1058, 1723
RIP: RFC-1058, 1727-27
RIP-2: RFC-1721-24
OSPF: RFC-1850, 1583, 1587, 1584
EGP: RFC-904, 911, 1092, 1093
BGP: RFC-1267, 1771, 1655-57
IDPR: RFC-1477, 1479
CLNP: RFC-1575, 1561, 1526
GGP: RFC-823, 1009, 1093
CIDR: RFC-1520, 1519

А остальное ищи в поисковиках.


Brand   (2002-06-16 22:48:00) [16]

Очень интерестно, а вот где-бы документацию почитать?


МИФИст   (2002-06-16 21:53:00) [17]

>SV
Я думаю ты имел в виду протоколы маршрутеризации: RIP, OSPF, IGRP, BGP-4. Только я совсем не уверен, что это можно сделать через RAW-сокеты, т.к. они не работают так, как описано в документации, об этом написано в статье( http://www.nestor.minsk.by/sr/sr0102/sr10210.htm).
Если же можно строить UDP пакеты, то к ним прицепить RIP и всё это через 520 порт.


МИФИст   (2002-06-16 21:31:00) [18]

>SV
Какой протокол ты имеешь в виду и как это флаг называется?


SV   (2002-06-16 18:32:00) [19]

Как мифист МИФИст"у: это можно сделать. Нужно поставить флаг в загаловке пакета, говорящий о жесткой моршрутизации + в опциях пакета перечислить все адреса узлов через которые он проходит.
Но помоему RAW-сокеты только в NT и только админам дают возможность править заголовок пакета.


МИФИст   (2002-06-16 18:12:00) [20]

>SV
То что он хочет узнать, он там не найдёт, да и вообще вряд ли это можно сделать, как-нибудь просто...


Страницы:   1 2

Наверх

Титульная страница Поиск, карта сайта Написать письмо