![]() |
| ||
|
|
Новости |
Поиск |
FAQ |
Статьи |
Книги |
Новости VCL
| | Форумы ЧАТ |
Орешник |
|
| |||
| |||
« предыдущая ветвь | форум | следующая ветвь »
Как скопировать файл из интернет на сервер?
Userrrrr © (2005-12-05 20:02:00)Как скопировать файл из интернет на сервер минуя компьютер на котором запущена программа?
Userrrrrr (2005-12-27 16:17:00) [1]а если закинут на один сервер свою программу и запускать её от сюда передовать ей команду а она будет копировать к сеюе с другого сервера но как это сделать?
Userrrrrr (2005-12-20 17:05:00) [2]Спасибо а по русски нет?
Alexander Panov (2005-12-18 21:15:00) [3]
When data is to be transferred between two servers, A and B (refer
to Figure 2), the user-PI, C, sets up control connections with
both server-PI's. One of the servers, say A, is then sent a PASV
command telling him to "listen" on his data port rather than
initiate a connection when he receives a transfer service command.
When the user-PI receives an acknowledgment to the PASV command,
which includes the identity of the host and port being listened
on, the user-PI then sends A's port, a, to B in a PORT command; a
reply is returned. The user-PI may then send the corresponding
service commands to A and B. Server B initiates the connection
and the transfer proceeds. The command-reply sequence is listed
below where the messages are vertically synchronous but
horizontally asynchronous:
Postel & Reynolds [Page 44]
\xC
RFC 959 October 1985
File Transfer Protocol
User-PI - Server A User-PI - Server B
------------------ ------------------
C->A : Connect C->B : Connect
C->A : PASV
A->C : 227 Entering Passive Mode.
A1,A2,A3,A4,a1,a2
C->B : PORT A1,A2,A3,A4,a1,a2
B->C : 200 Okay
C->A : STOR C->B : RETR
B->A : Connect to HOST-A, PORT-a
Figure 3
The data connection shall be closed by the server under the
conditions described in the Section on Establishing Data
Connections. If the data connection is to be closed following a
data transfer where closing the connection is not required to
indicate the end-of-file, the server must do so immediately.
Waiting until after a new transfer command is not permitted
because the user-process will have already tested the data
connection to see if it needs to do a "listen"; (remember that the
user must "listen" on a closed data port BEFORE sending the
transfer request). To prevent a race condition here, the server
sends a reply (226) after closing the data connection (or if the
connection is left open, a "file transfer completed" reply (250)
and the user-PI should wait for one of these replies before
issuing a new transfer command).
Any time either the user or server see that the connection is
being closed by the other side, it should promptly read any
remaining data queued on the connection and issue the close on its
own side.
Userrrrrr (2005-12-18 14:16:00) [4]Ладно, если у меня нет доступа к машине через которую необходимо скачать файл, а файл этот лежит вообще где-нибудь далеко (может там и ftp не работает) или например мне надо скачать файлы (прогноз погоды к примеру в архиве) с разных сайтов, но при этом минимизировать входиящий трафик из интернета на лично мой комп.
Userrrrrr (2005-12-13 17:31:00) [5]так как это осущиствить
wal (2005-12-13 17:26:00) [6]про 2 вопрос не стоит.
Если 1 твоя, то поднимай на ней любое удаленное управление, хоть telnet, хоть rdp. На вкус и на цвет карандаши разные.
С машины 3 подсоединяйся к 1 и рули ей как больше нравится, например дай задание скачать что-то с машины 2, по любому, доступному на 2 протоколу.
Вариант с линкованием двух ftp-серверов тоже красивый, но несколько более сложный.
> а если нет?
А на нет и суда нет, но есть особое совещание (с)
Тогда вариант только линковкой ftp-серверов, но для этого и на 1 и на 2 ftp-сервера нужны.
Userrrrrr (2005-12-13 17:10:00) [7]1 мой а 2 в принципе может и могу хотя... а если нет?
wal (2005-12-13 17:09:00) [8]
> а какие сервисы хрен их знает!
Ну тогда продолжим пытку вопросами ;)
Машины 1 и 3 твои? То есть можешь установить там нужные программы, сервисы и т.д.?
Userrrrrr (2005-12-13 17:06:00) [9]вообще все машины имеют доступ друг к другу
а какие сервисы хрен их знает!
wal (2005-12-13 16:52:00) [10]Еще раз повторяю вопрос.
Мы имеем три машины
1. Сервер в локальной сети дома
2. Сервер где-то в интернете
3. Рабочее место
Вопросы:
Машина 1 имеет доступ по сети к машине 2?
Машина 2 имеет доступ по сети к машине 1?
Машина 3 имеет доступ по сети к машине 1?
Машина 3 имеет доступ по сети к машине 2?
Какие сетевые сервисы есть на машине 1?
Какие сетевые сервисы есть на машине 2?
Когда ответишь на эти вопросы, будем искать варианты.
С уважением.
Userrrrrr (2005-12-13 16:46:00) [11]Ситуация: сервер1 front.ru - сайт там
сервер2 в локальной сети дома
wal (2005-12-13 16:38:00) [12]
> есть сервер в локальной сети
> и сервер в глобалной сети
> скопировать файлы на локальный сервер при этом менимизировать
> трафик через мой компьютер
1. Серверы друг другу видны?
2. Какие сервисы крутятся на серверах?
Userrrrrr (2005-12-13 16:34:00) [13]так может кто знает как это зделать?
Userrrrrr (2005-12-08 23:53:00) [14]Спасибо конечно но читать то надо на английском а это... может у кого по русски есть?
Alexander Panov (2005-12-08 23:21:00) [15]Userrrrrr (08.12.05 8:30) [11]
Почитай RFC про протокол FTP. Помнится, есть такая фишка - копирование с сервера на сервер без предварительного перекачивания на станцию. Не помню, как это называется правильно.
DrPass (2005-12-08 23:11:00) [16]...начни с просмотра фильма "Хакеры"
Anatoly Podgoretsky (2005-12-08 20:40:00) [17]Userrrrrr (08.12.05 20:22) [13]
Это не программы, это первичные руководящие документы, их надо читать и вникать.
Userrrrrr (2005-12-08 20:22:00) [18]А как с этим работать?
Leonid Troyanovsky (2005-12-08 08:38:00) [19]
> Userrrrrr (08.12.05 08:30) [11]
> telnet + ftp - а можно по подробнее или статью какую почитать
> а точто telnet + ftp это понятно итак
RFC-959 FTP
RFC-854 TELNET PROTOCOL SPECIFICATION
RFC-855 TELNET OPTION SPECIFICATIONS
RFC-856 TELNET BINARY TRANSMISSION
RFC-857 TELNET ECHO OPTION
RFC-858 TELNET SUPPRESS GO AHEAD OPTION
RFC-859 TELNET STATUS OPTION
RFC-860 TELNET TIMING MARK OPTION
RFC-861 TELNET EXTENDED OPTIONS - LIST OPTION
RFC-885 TELNET END OF RECORD OPTION
RFC-1073 Telnet Window Size Option
RFC-1079 Telnet Terminal Speed Option
RFC-1091 Telnet Terminal-Type Option
RFC-1096 Telnet X Display Location Option
RFC-1123 Requirements for Internet Hosts -- Application and Support
RFC-1184 Telnet Linemode Option
RFC-1372 Telnet Remote Flow Control Option
RFC-1416 Telnet Authentication Option
RFC-1411 Telnet Authentication: Kerberos Version 4
RFC-1412 Telnet Authentication: SPX
RFC-1571 Telnet Environment Option Interoperability Issues
RFC-1572 Telnet Environment Option
--
Regards, LVT.
Userrrrrr (2005-12-08 08:30:00) [20]Вообщем есть сервер в локальной сети доступ к нему есть конечно (а если нету что тоже можно???)))) и сервер в глобалной сети надо скопировать файлы на локальный сервер при этом менимизировать трафик через мой компьютер
telnet + ftp - а можно по подробнее или статью какую почитать а точто telnet + ftp это понятно итак